Synology DSM 6: Incompatible Packages

Now that Synology has released the first production version of DiskStation Manager 6 (DSM 6) it’s time to seriously consider upgrading. I keep a DS212+ NAS with most Synology packages installed, so that I can monitor updates and changes. It has nearly all the packages available in Package Manager installed, the only exceptions being ones that conflict with an already installed package. For example, OpenERP 6 and OpenERP 7 can’t both be installed so I installed OpenERP 7. It was time to upgrade this NAS to DSM 6. These are the packages that did not survive the upgrade.

Just about every package needs an update after the DiskStation Manager 6 upgrade so allow plenty of time to get things running. A few do update as part of the upgrade but most will need your attention after the upgrade.

The ground rules:

    • Only packages available through the DSM package manager are considered.
    • If the package is not upgradeable (or fixable) through Package Manager then it is incompatible from my point of view. You may be able to side-load an update, but you’ll need to visit the creators website for information.
    • The DSM 6 Upgrade was done after DSM 5 and all installed packages were updated to their latest versions. I always recommend verifying that the latest versions of all packages are installed before updating DSM, even though you’ll (most likely) need to update them again after upgrading the DSM 6.

If you’re using any of the packages listed below you’ll need to do your research before upgrading, or wait and see if updates appear in Package Manager.

Asterisk

The DSM 6 release notes say this is no longer supported by the open source team, so Synology is not supporting it in DSM 6. It will not run after the upgrade.

WonderBox

I had to uninstall this package in order to run the DSM 6 upgrade. It wouldn’t shut down and the upgrade wouldn’t proceed with it running. The package is not available in the DSM 6 Package Manager.

BitTorrent Sync

This wouldn’t run after the upgrade. No update is available in Package Manager.

Synology CMS (Control Management System)

This is not supported on all Synology Hardware. Hardware that installed it in DSM 5 may not support it in DSM 6. For example, my DS212+ would not run it after the DSM 6 upgrade and no update was available. The package is available under DSM 6 on other hardware, such as the DS1815+.

Elephant Drive

This did not run after the DSM 6 upgrade and no update is available in the DSM 6 Package Manager.

Plex Media Server

This did not run after the DSM 6 upgrade and no update is available in the DSM 6 Package Manager. The Plex website does have newer versions for Synology that include support for the DSM 6 beta, so I would expect a version to show up in Package Manager in the near future.

Synform Cloud Backup

This did not run after the DSM 6 upgrade and no update is available in the DSM 6 Package Manager. The Synology forums included some threads complaining about the DSM 5 version of this package, so it may be awhile before it shows up.

xCloud

This did not run after the DSM 6 upgrade and no update is available in the DSM 6 Package Manager.

Zarafa

This did not run after the DSM 6 upgrade and no update is available in the DSM 6 Package Manager.

Leave a Reply

Your email address will not be published. Required fields are marked *